1. Home
  2. Account Basics
  3. Getting Started
  4. What are the system requirements and supported browsers on educateWorkforce?

What are the system requirements and supported browsers on educateWorkforce?

No special equipment is required to access all of EducateWorkforce’s features. Most desktops and laptops with a solid internet connection will work well.

Most current browsers will work on EducateWorkforce. For best performance, we recommend the latest versions of:

We also support the latest versions of:

Troubleshooting Browser Problems

Many problems with missing form fields, buttons that do not function, or other page display issues are caused by your browser. Here are some things to try to fix viewing problems:

  • Make sure your browser is the most current version.
  • Check your browser settings to make sure both JavaScript and cookies are enabled.
  • Clear your browser’s cache. Here are instructions on clearing your cache in Chrome or Firefox.

Simulation Support

The virtual reality simulations are best viewed from a desktop computer browser interface and are not recommended for use on smartphones and tablets on both Android and iOS platforms since they require keyboard and mouse devices for interaction.

Note: The simulations are developed using the Unity 3D game engine. Please refer to the WebGL Browser Compatibility documentation for more details about browser compatibility.

Updated on September 17, 2021

Was this article helpful?

Related Articles